A/C blowing hot

Discussion in 'Fiesta ST Maintenance' started by Autonomous, Jul 21, 2014.

  1. Autonomous

    Autonomous New Member

    Friday my climate control worked perfectly, didn't drive all weekend, this morning it would not cool even a little. Cycled settings, tried voice control, even restarted car twice. It feels like the unit was not engaging.

    Had no time to call service yet so figured this is the place to get a rep's attention.

    Anyone have this issue before?
  2. Register or Sign in

    Advertisement Sponsor

  3. reddog99

    reddog99 Active Member

    Not to be a smart-ass, but the rep here can't fix it for you. Best to take it directly to the dealer...
    SpaceFish and LuvfiestaST like this.
  4. Autonomous

    Autonomous New Member

    Lol. Nah not sounding like a smart ass at all. Made an appointment for 8am about an hour after this post. Was just looking to see if anyone had a quick answer, as it's all circuit based I thought maybe there was some sort of reboot to try but no luck.
  5. RodMoe

    RodMoe Well-Known Member

    Read on one of the forums that a member had a issue with a weak AC control module or something and leaving the battery unhooked for a hour or more reset it and the dealer has parts ordered. Think he left the battery off overnight . That helped him ymmv
  6. Autonomous

    Autonomous New Member

    Thanks for the tip. I work odd hours, so when I took the car in this morning I got to see my driveway in the daylight, it looked damp so I had an idea of what happened. Got a call from the dealership, said compressor was leaking and a new compressor would be delivered in the morning and ready to drive home tomorrow.
  7. ISO100

    ISO100 Member

    This happened to me recently. I tried turning the AC off and back on with no luck. Pressing the front defrost button seemed to resolve it however.

Share This Page