A/C completely and thoroughly died, and then……..

Discussion in 'Fiesta ST Chat and Discussion' started by OrangeFist, Aug 21, 2014.

  1. OrangeFist

    OrangeFist Member

    I brought my car to the dealer to have my Mountune Quick Shift installed. Nice!!
    When I drove it home, I noticed the A/C was completely dead and blowing hot air. It was colder outside!.

    Went back to the dealer: "Your tech knocked out my AC." Anyway, they checked all the connections and the tech did not make any mistake, except it just wasn't working :(. Made an appointment to have the problem diagnosed. Next morning I thought I was going to drive around in a hot car. I start the car and it worked all of a sudden, A/C was refrigerator cold as if nothing happened. Called the service writer and cancelled the appointment.

    We fiddled with the switches to now avail. Checked the coolant and it was fine. Should I have used the voice commands to turn it on and off?

    Does anyone any idea what may have happened?
  2. Register or Sign in

    Advertisement Sponsor

  3. ISO100

    ISO100 Member

    My ac died temporarily after a reflash. No physical changes to the car. The "fix" was putting it in defrost mode. Hasn't happened since.
  4. bobjob

    bobjob Active Member

    I had the exact same thing happen after I had my quick shift installed. Ac just turned on after 40 mins of driving
  5. OrangeFist

    OrangeFist Member

    Isn't that the strangest thing? :confused:
  6. Roger

    Roger New Member

    Mine did it too after I installed the quick shift. I let it sit overnight and magically it worked again.
  7. WScottCross

    WScottCross Well-Known Member

    Did you guys pull the battery when you did the quick shift install?
  8. Roger

    Roger New Member

    I did with the quick shift, but the ac issue also came up with swapping the intake without removing the battery.
  9. Mikeygti

    Mikeygti Active Member

    Same here !

    Sent from my iPad using Tapatalk
  10. mrtn

    mrtn Active Member

    I'll have to look out for this. I just installed a quick shift and removed my battery. But the only thing I noticed not working was the one touch window up and down.
  11. ISO100

    ISO100 Member

    You probably just need to retrain the limits.
  12. mrtn

    mrtn Active Member

  13. ISO100

    ISO100 Member

    I believe you need to manually roll the window down all the way and back up all the way a few times. Then it will do the auto down and up again.
    OrangeFist likes this.
  14. mrtn

    mrtn Active Member

    Ahh ok. Thanks I'll give that a try!
  15. reddog99

    reddog99 Active Member

    There's instructions in the owner's manual for auto down and up if you get confused.

Share This Page