Clicking/popping from front end

Discussion in 'Fiesta ST Maintenance' started by AlanBDahl, Apr 12, 2017.

  1. AlanBDahl

    AlanBDahl Active Member

    I’m getting a clicking or popping sound from the front end of my 2014 Fiesta ST. It was fine Sunday when I did my second autocross of the season but on Monday afternoon I first noticed the sound and it’s getting more frequent. It seems to be coming from the left front but could be anything from suspension issues to a heat shield. It almost sounds like a minor ping/backfire but it still does it with the engine off so it’s obviously not that. FYI I have Koni shocks on the car and 70,000 miles overall. I do race it occasionally but only about 10 events a year on average.

    So far I’ve retorqued the lugs and done a quick inspection for loose or broken bits and not found anything. I’ve thought about taking it to the dealer but I am concerned that with the Koni shocks they might not be able to fix things if the issue turns out to be shock related. I have another mechanic thats into building race cars in addition to normal service but he’s so booked up right now I can’t even get him to pick up the phone.
     
  2. Register or Sign in

    Advertisement Sponsor

     
  3. AlanBDahl

    AlanBDahl Active Member

    Turns out that I had a piece of wire or metal lodged up in the spring on one side. Neither I nor the dealer have any idea how it got lodged up there!
     
  4. reddog99

    reddog99 Active Member

    Thanks for solving the mystery!
     

Share This Page