Heater not working?

Discussion in 'Fiesta ST Maintenance' started by speedprotege, Jan 3, 2014.

  1. marc89gti

    marc89gti Active Member

    I have the part numbers from the service order, should be able to search on Fordparts.com

    Sent from my iPhone using Tapatalk
  2. Register or Sign in

    Advertisement Sponsor

  3. WScottCross

    WScottCross Well-Known Member

    OK, I didn't notice the piece under the foam until i zoomed in. Mine is garaged at home, but sits outside while I'm at work and therefore I'll be asking to have mine done as well.
  4. marc89gti

    marc89gti Active Member

    I did a Google search and the grill portion in the three pictures I attached showed the same thing as online pics. So now I'm not too sure what exactly the dealer installed. The installed 2 screens - part number D2BZ-18D395-A and 4 clips BE8Z-14197-A. Can't finds pics online though

    Sent from my Nexus 7 using Tapatalk
  5. RodMoe

    RodMoe Well-Known Member

    Here are mine.. Car was built in 09/13 if that matters

    All Three vents have the grills
  6. Smokin

    Smokin Active Member

    I see no small strips...
  7. marc89gti

    marc89gti Active Member

    Are you saying on your car you have no small strips below the foamy portion and basically have a big hole for where the air enters the car? My car was built 7/2013.
  8. btcca4

    btcca4 New Member

    Not sure how your dealer came up with those p/n's? The correct p/n is CE8Z-54020C16-A deflector kit. This kit contains 3 covers with clips & foam weatherstrips to seal off the cowl from the outside elements. The foam weatherstrip seals the cowl to the hood. No snow, ice, leaves or twigs can get into the ducts now.
  9. marc89gti

    marc89gti Active Member


    Not sure about your part number, is there a TSB that refers to fixing the problem with the part number you have shown?

    The TSB my repair was done under is 13-11-17.

    Sent from my iPhone using Tapatalk
  10. marc89gti

    marc89gti Active Member

    Can you take picture of this deflector kit you have had installed, curious to compare to what my dealer installed.

    Sent from my iPhone using Tapatalk
  11. LuvfiestaST

    LuvfiestaST Active Member

    Seems my car came with those 3 vents/sponges installed alreadyz..;))
  12. btcca4

    btcca4 New Member

    They look just like the deflectors Luvfiesta ST posted above. As far as I know, that is the correct TSB your car was repaired under. Confusing why 2 screens & 4 clips are billed out on the RO?? The parts manager showed me the box, in it were 3 shrouds with foam weatherstrip on them. They clip on over the existing screens on the cowl. Maybe the p/n is superseded?
  13. RodMoe

    RodMoe Well-Known Member

    So your car had NONE before this? I mean the foam vent shrouds
  14. marc89gti

    marc89gti Active Member

    I do remember before taking my car to the dealer it definitely had the foam strip portion. But for some reason I thought my car didn't have the screen portion. I think my car was one of the earlier builds 7/13, so who knows maybe they started to add these screens in a few months later. The pictures I took after picking up my car from the dealer and posting in an earlier post also look like the pictures that Luvfiesta ST posted as well.
  15. reddog99

    reddog99 Active Member

    FWIW, I just checked my car and the grill is wide open to everything. I can even look into the grill with the hood closed. Luckily, snow weather around here, even in the mountains, is sparse so I don't have much worry about. For reference, my build date is 9/2013.
  16. RodMoe

    RodMoe Well-Known Member

    Any chance of Pic's ??
  17. LuvfiestaST

    LuvfiestaST Active Member

    Some little fucker was texting on the line and skipped a few cars..))
  18. stuntdoogie

    stuntdoogie Active Member

    Took a pic of mine. Could you tell me if mine has that strip you talk about cause ai have no clue what you are talking about.

    Sent from my SPH-D710 using Tapatalk
  19. marc89gti

    marc89gti Active Member

    You have the small strips or grill portion below the foam for the three air intakes. I have seen some pictures online of Fiesta St's where they didn't have the foam portion on the air intakes. Perhaps the first 3-4 months of production was missing the foam and strips or grill portion.
  20. marc89gti

    marc89gti Active Member

  21. RodMoe

    RodMoe Well-Known Member

    Weird how even on that site some have and some don't !!

Share This Page