High cold idle

Discussion in 'Fiesta ST Maintenance' started by eqc.liu, Feb 20, 2015.

  1. eqc.liu

    eqc.liu New Member

    Hey guys, so if you haven't heard, New England is battling very cold temperatures lately. It was probably around 5F (-15C) this morning and I preheated my car for about 10 minutes. After getting into the car, I realized that it was still idling at 2500 rpm. This has happened to one once before during a very cold morning (normally after 10 minutes the car would be idling at 800 rpm). I tried gently revving the engine but it still returned to it's 2500 rpm. Only after putting load on the engine by pulling out of my driveway did the idle rpm drop to around 1000, and then down to about 800 rpm at the next light.

    I know the engine is supposed to idle high when it's cold out, but this seems a bit excessive. Also it was strange that right after I put load on the engine, the idle dropped down. Has anyone had an issue like this? Anyone know how to fix it?
  2. Register or Sign in

    Advertisement Sponsor

  3. timboslice

    timboslice Active Member

    Completely normal. The ecu does this automatically. Mine does the same, so did my Mazda.

    Sent from my iPhone using Tapatalk
  4. LT Berzerker

    LT Berzerker Active Member

    -13 yesterday according to the car when I started it... Nothing to worry about, mine will idle 1500 then jump up, then back down once op temp/thermostat opens
  5. eqc.liu

    eqc.liu New Member

    Okay good to know. Now if I can only get the car to stop rattling when it's cold...:(
    LuvfiestaST likes this.
  6. timboslice

    timboslice Active Member

    Try the block heater? It's one of the hidden feature I keep forgetting about.

Share This Page