Loud clicking in dash after startup

Discussion in 'Fiesta ST Chat and Discussion' started by Samridgebag, Dec 2, 2014.

  1. Samridgebag

    Samridgebag New Member

    Yesterday, my 2014 FiST started producing a series of loud clicking sounds emanating from the center of the dash. The clicks start shortly after the car is started and only last about 8 seconds. This evening, I captured the strangeness on video. I am curious if anyone else has experienced this and what folks think the cause might be.
  2. Register or Sign in

    Advertisement Sponsor

  3. Applejack

    Applejack Active Member

    I am throwing a guess out... Maybe HVAC servos. You may want to take that to the dealer.
  4. FORZDA 2

    FORZDA 2 Member

    Sure sounds like the "clicking" is simply the OP banging on something in the car. Those are not "normal" failure sounds of anything inside the car.

    I call bullshit on this one.
  5. Sil3nt611

    Sil3nt611 Active Member

    Our on-site Mustang at work has a clicking coming from the dash that is a known problem for Mustangs to be the HVAC servos. That sounds like pretty much the same thing. More than likely covered under warranty.
  6. FordService

    FordService Official Ford Representative

    Hi again,

    Since we're already talking on the other forum, I'll keep the conversation going over there. :) Just wanted to drop a line so you knew I was here, too.

  7. Eric Pittman

    Eric Pittman New Member

    I had the same issue. Fixed under warranty. Hvac motor.

    Sent from my SCH-I545 using Tapatalk

Share This Page