MFT Issues?

Discussion in 'Fiesta ST Chat and Discussion' started by ST-in-Mich, Jun 16, 2014.

  1. ST-in-Mich

    ST-in-Mich Member

    Recently I've been having a lot of issues regard MFT and my phone. In the past 3 days MFT has crashed when my phone receives a text or call, and then either:

    A) goes black screen with music still playing until I stop and restart the car, or
    B)Shuts off completely, turning TC back on, radio goes off and takes ~3-4 mins while it reboots and they has a loading bar with something like 'scheduled maintenance' on it.

    I also had it go out on me once when changing the radio station using the touch screen.

    Anyone else having, or had these issues before?
  2. Register or Sign in

    Advertisement Sponsor

  3. ohskigod

    ohskigod Member

    I've had wierd little glitches that make me question the longevity of the system long term, but to that level? no.

    Get that thing to the dealer.

    Frikkin Microsoft, its a crime that Bill Gates has the money he has given the crap that company puts out.
  4. iLiptiKal

    iLiptiKal Active Member

    The only issue I've encountered so far is sometimes when I am using my phone to listen to music when plugged in via USB. If I shut the car off without unplugging my phone first, when I turn the car back on without plugging in my phone again the car will try to play from my phone and not respond for quite some time until it realizes my phone isn't plugged in and switches to FM radio.
  5. eRic

    eRic Active Member

    take it in and see if you have the latest sync update? I have an iPhone and have had zero issues with myfordtouch in mine.
  6. SpaceFish

    SpaceFish Member

    The MFT system in my Focus ST was plagued with problems (even after replacing the thing it still was wonky and the main reason I got rid of it quickly). Alas it seems that some of things are possessed by the devil. Thankfully (knocks loudly on desk) I have been very lucky this time around.

    As eRic says, first step is to ensure you have the most current version (that fixed a few of my issues on the Focus). Also, what kind of phone do you have, OP?
  7. ST-in-Mich

    ST-in-Mich Member

    I have an Android phone, Galaxy Note 3.

    I will call my dealership and see if i can get in there to have it looked at or updated.
  8. SpaceFish

    SpaceFish Member

    I have the same phone (Verizon/4.4.2) with no issues here. Good luck!
  9. stuntdoogie

    stuntdoogie Active Member

    My mft bluetoothe disconnects from my Epic 4G too often. Have to hit reconnect often. Sucks.

    Sent from my SPH-D710 using Tapatalk
  10. FordIVTteam

    FordIVTteam Official Ford Representative

    Hi ST-in-Mich,

    The first thing I recommend is performing a master reset to your MyFord Touch system. This is odd behavior and a reset is definitely in order. Once the reset is complete, you will notice that your phone will no longer be connected and you’ll need to pair it again. Here are the instructions for the reset:

    eRic and SpaceFish had a great suggestion also. Check to make sure you’re running the latest software version for your vehicle. The easiest way to check is to log into your account at:

    Hint: the latest version is V3.6.2. If you press the 2 gears > HELP > SYSTEM INFORMATION the last 5 digits of the CCPU number will say 13171 if this version has already been installed.
    Hello iLiptiKal,

    The next time you notice a delay like this, try pressing the VOICE COMMAND button on the steering wheel to quickly change the source to the one you prefer. Here are some voice commands that can be used:
    This sounds like a common Bluetooth connection issue, stuntdoogie. This is normally resolved by performing a soft reset to your cell phone. If your battery is removable, take it out for about 30 seconds and replace it. When the phone boots back up, it should still automatically connect to your MyFord Touch system. You’ll find other connection tips on this page:

    Last edited: Jul 20, 2014
  11. ST-in-Mich

    ST-in-Mich Member

    Alright, so update to this:

    I did the master reset and made sure I had the most updated version of the system. That worked for that moment, but it started happening again yesterday, and i brushed it off as a fluke. Now today this morning on my way to work, the system wasn't responding and when i shut my car off and got out THE SPEAKERS WERE STILL PLAYING THE RADIO.

    I called my ford dealer and all i got for an answer is to disconnect my battery, and wait until i can get in which they said may not be for a few days.

    Quick edit: I called and was told I cant even get in until the 31st. wow.
  12. sumo64c

    sumo64c Member

    hard reset again and leave it off.....easier than disconnecting the battery every time. I have a note 2 and have had no issues at all since day 1. Hope you get your issue fixed.
  13. FordIVTteam

    FordIVTteam Official Ford Representative

    Hi ST-in-Mich,

    Since the master reset only seems to be resolving your concern temporarily, I think you're on the right track. The dealership should take a closer look to see what's going on. Let us know how your appointment goes.


Share This Page