New website is live!!

Discussion in 'Tasca Auto Group' started by Steve@Tasca, May 13, 2014.

  1. Steve@Tasca

    Steve@Tasca Fiesta ST Network Sponsor

    Hey all, Great news!! We have just launched our brand new parts website and it's live as of this morning, much more modern and user friendly than the old one with the added features of VIN driven cataloging (when applicable) and accurate shipping costs displayed at checkout. There are also features on the backside of the site for us that should make for a much more efficient and accurate process. Please check out the new site and there's even a "Feedback" tab on the left side of the screen so you can let us know what you think and it should help us improve on any weak points. [​IMG]

    Last edited: May 14, 2014
    dmondi12 and Firesail like this.
  2. Register or Sign in

    Advertisement Sponsor

  3. Firesail

    Firesail Active Member

    Looks great! Much easier to use.
  4. WScottCross

    WScottCross Well-Known Member

    I like the new site, but your link was broken and took me to facebook.
  5. Steve@Tasca

    Steve@Tasca Fiesta ST Network Sponsor

    Was being the key word, a few others had issues with the link earlier as well.
  6. Zormecteon

    Zormecteon Active Member

    the link on this page IS broken. It goes to Facebook and won't load... this is as of Tuesday evening, May 13th. .. by typing the link into the address bar I am able to access the websight.
  7. D1JL

    D1JL Well-Known Member

  8. WScottCross

    WScottCross Well-Known Member

    Nope. Still wrong. Hover over it and it still shows that it's trying to take us to Facebook. Dave's link works.
  9. Steve@Tasca

    Steve@Tasca Fiesta ST Network Sponsor

    Bizarre, it was working for me. What browsers are you guys using?

    I just copied in a new link in my original post, no reason it shouldn't work now and I'll also copy and paste it here

    My sig banner also leads directly to the new website.

  10. moff3tt

    moff3tt Active Member

    It could be the DNS propagation sometimes that takes a while.
  11. WScottCross

    WScottCross Well-Known Member

    Working now. I use IE at work and Firefox at home.
  12. Steve@Tasca

    Steve@Tasca Fiesta ST Network Sponsor

    I use Firefox at work for the forums side of things and IE for stuff that I need for the systems that aren't compatible with Firefox and I do know that my Firefox wasn't happy about the switch over using the link until I cleared my cache but IE picked up on it right away.
  13. justinsane

    justinsane New Member

    Wow looks a lot less 2004!
    Steve@Tasca likes this.
  14. svt3d

    svt3d Member

    Way better on Safari everything seems to work great!

Share This Page